Ein Entity-Relationship-Diagramm in Lucidchart erstellen

Geschrieben von:  Morgan T
Letzte Aktualisierung:  

Erstellen Sie Entity-Relationship-Diagramme (ERDs) und passen Sie den Text, die Gestaltung und die Beziehungen zwischen Feldern individuell an. Erstellen Sie automatisch Datenbanktabellen und Schemata mithilfe unserer SQL-Import-Funktion.

Planverfügbarkeit: kostenlos, Individuell, Team und Enterprise.

Sehen Sie sich an: Entity-Relationship-Diagramm

ERD-Übersicht

Ein Entity-Relationship-Diagramm (ERD) ist eine visuelle Darstellung einer Datenbank, die zeigt, wie die Elemente darin miteinander in Beziehung stehen. Ein ER-Diagramm besteht aus zwei Objekttypen – Entitäten und Beziehungen. Eine Entität ist in diesem Zusammenhang eine Datenkomponente aus dem Datenbestand, die als Form auf der Leinwand dargestellt wird. Die Beziehungen zwischen den Entitäten werden als Linien dargestellt, die spezielle Linienenden haben, die Kardinalitäten genannt werden und die beschreiben, wie zwei Elemente der Datenbank miteinander interagieren.

Eine Datenbank importieren

Die Funktion für den ERD-Import lädt alle Ihre Datenbanktabellen und Schemata direkt in Ihr Formenmenü hoch. Sie können jederzeit aktualisierte Datenbank-Dateien importieren, und die Felder werden im Formenmenü und auf der Arbeitsfläche aktualisiert.

Zum Importieren Ihrer Datenbankkomponenten gehen Sie folgendermaßen vor:

  1. Klicken Sie auf search-icon.png das Suchsymbol oben links auf der Leinwand.
  2. Wählen Sie im linken Panel "Aus Daten erstellen " aus.
  3. Wählen Sie die Kachel "Entitätsrelation (ERD)".
  4. Im Dropdown-Menü "Daten importieren" wählen Sie aus SQL-Datenbank importieren.
  5. Wählen Sie im Dropdown-Menü aus, welches Datenbankverwaltungssystem (DMBS) Sie verwenden
  6. Wähle "Kopieren auf Zwischenablage", um die Anfrage zu kopieren , und führe sie dann in deiner Datenbank aus.
  7. Navigiere zurück zu Lucid und klicke unten rechts im Fenster auf Nächst.
  8. Lade die Ergebnisse als Datei von deinem Computer hoch oder füge die Ausgabe als Klartext ein.
  9. Klicken Sie auf Importieren.

Für vollständige Anweisungen zum Importieren einer Datenbank im klassischen Lucidchart-Editor erweitern Sie bitte das untenstehende Dropdown-Menü.

Klicken Sie hier für die klassischen Lucidchart Editor-Schritte

Zum Importieren Ihrer Datenbankkomponenten gehen Sie folgendermaßen vor:

  1. Öffnen Sie den Formenbibliothek-Manager, indem Sie unten im Formenmenü auf Weitere Formen klicken.
  2. Suchen Sie nach der Shape-Bibliothek „Entity Relationship“.
  3. Klicken Sie auf das Kontrollkästchen neben „Entity Relationship“.
  4. Wählen Sie Ausgewählte Formen verwenden.
  5. Klicken Sie auf Import aus der Entitätsrelation Formenbibliothek.
  6. Im Importmenü wählen Sie das Datenbankverwaltungssystem (DBMS) aus, das Sie verwenden.

     
  7. Klicken Sie auf Kopieren in Zwischenablage, um die Anfrage zu kopieren. 
  8. Fügen Sie die Abfrage ein und führen Sie diese in Ihrer Datenbank aus.
  9. Wählen Sie Weiter.
  10. Klicken Sie auf Wählen Sie Datei, um Ihre .CSV-, .TSV- oder .TXT-Datei zu importieren. 
    • Alternativ können Sie die Anfrage Ergebnisse in den Offener Textbereich kopieren und einfügen. 
  11. Klicken Sie auf Importieren.   

 

Lucidchart wandelt die importierte Anfrage sofort in eine Liste von Datenbanktabellen, Schemata um und organisiert die Liste in Ihrer Formenmenü. Jeder zusammenklappbare Abschnitt der Formenmenü stellt eine Datenbank dar. Die Namen innerhalb eines Abschnitts entsprechen Datenbanktabellen. Ein zusätzlicher Unterabschnitt würde ein Schema anzeigen.

Anschließend können Sie die Datenbanktabellen aus dem Formenmenü auf die Arbeitsfläche ziehen. Wenn Sie die Primär- und Fremdschlüssel richtig eingerichtet haben, zeichnet Lucidchart automatisch Beziehungslinien, wenn Sie verknüpfte Tabellen auf die Arbeitsfläche ziehen.

Importieren eines Salesforce-Schemas  enterprise-tag.png

Mit dem Schema-Import von Salesforce können Admins die Architektur ihrer Salesforce-Instanzen darstellen.

Hinweis: Diese Funktion ist nur für Enterprise-Konten verfügbar und steht Benutzern in der FedRAMP-Umgebung nicht zur Verfügung. 

So importieren Sie Ihr Schema:

  1. Klicken Sie search-icon.png auf das Suchsymbol in der oberen linken Ecke der Leinwand.
  2. Wählen Sie im linken Panel "Aus Daten erstellen " aus.
  3. Wählen Sie die Kachel "Entitätsrelation (ERD)".
  4. Im Dropdown-Menü "Daten importieren" wählen Sie Import from Salesforce.
  5. Im nächsten Fenster werden Sie aufgefordert, sich bei Salesforce anzumelden. Klicken Sie auf Weitermachen.
  6. Wenn Sie bisher noch nicht mit Salesforce verknüpft haben, wird das nächste Fenster Sie auffordern, Lucidchart die Berechtigung zum Zugriff auf Ihr Salesforce-Konto zu erteilen. Klicken Sie auf Zulassen.
    • Sie können den Zugang jederzeit in Ihren Lucid-Kontoeinstellungen widerrufen. 
    • Wenn Sie nach diesem Schritt eine Fehlermeldung erhalten, überprüfen Sie bitte Ihre Anmelde-IP-Bereiche unter Ihrem Salesforce-Benutzerprofil und stellen Sie sicher, dass diese Bereiche nicht eingeschränkt sind. 
  7. Wählen Sie im nächsten Fenster aus, welche Salesforce-Objekte Sie in Lucidchart importieren möchten.
  8. Suche in der Suchleiste oben nach bestimmten Objekten. Wenn keine Objekte gefunden werden, werden Sie aufgefordert, Ihren Suchbegriff anzupassen.
  9. Wähle zwischen "Nur Relation anzeigen" und "Alle Objektdetails anzeigen".
  10. Klicken Sie auf Import. 

Für vollständige Anweisungen zum Importieren Ihres Schemas in den klassischen Lucidchart-Editor erweitern Sie bitte das untenstehende Dropdown-Menü.

Klicken Sie hier für die klassischen Lucidchart Editor-Schritte

So importieren Sie Ihr Schema:

  1. Öffnen Sie den Formenbibliothek-Manager, indem Sie unten im Formenmenü auf Weitere Formen klicken.
  2. Suchen Sie nach der Shape-Bibliothek „Entity Relationship“.
  3. Klicken Sie auf das Kontrollkästchen neben „Entity Relationship“.
  4. Wählen Sie Ausgewählte Formen verwenden.
  5. Klicken Sie in der Entitätsrelation Formenbibliothek auf Salesforce Import.
  6. Klicken Sie in dem sich öffnenden Dialogfeld auf Aus Salesforce importieren.
  7. Im nächsten Fenster werden Sie aufgefordert, sich bei Salesforce anzumelden. Klicken Sie auf Weiter.
  8. Wenn Sie noch keine Verbindung zu Salesforce hergestellt haben, werden Sie im nächsten Fenster aufgefordert, Lucidchart die Erlaubnis zu erteilen, auf Ihr Salesforce-Konto zuzugreifen. Klicken Sie auf Erlauben.
    • Sie können den Zugang jederzeit in Ihren Lucid-Kontoeinstellungen widerrufen. 
    • Wenn Sie nach diesem Schritt eine Fehlermeldung erhalten, überprüfen Sie bitte Ihre Anmelde-IP-Bereiche unter Ihrem Salesforce-Benutzerprofil und stellen Sie sicher, dass diese Bereiche nicht eingeschränkt sind. 
  9. Wählen Sie im nächsten Fenster aus, welche Salesforce-Objekte Sie in Lucidchart importieren möchten.
    • Suche in der Suchleiste oben nach bestimmten Objekten. Wenn keine Objekte gefunden werden, werden Sie aufgefordert, Ihren Suchbegriff anzupassen.
  10. Wähle zwischen "Nur Relation anzeigen" und "Alle Objektdetails anzeigen".
  11. Klicken Sie auf Importieren.

 

Ein ERD aktualisieren

Um Ihr ERD zu aktualisieren, folgen Sie den oben genannten Schritten den entsprechenden Abschnitten. Nachdem du im letzten Schritt auf Importieren geklickt hast, erscheint ein Popup-Fenster. Wählen Sie eine der folgenden Optionen:

  • Nein, nur Toolbox: Aktualisieren Sie das Formular in Ihrer Toolbox.
  • Ja: Aktualisiere das bereits auf der Leinwand liegende Formular sowie in deinem Werkzeugkasten.

Ein ERD manuell erstellen oder bearbeiten

Mithilfe der Entitätsrelation Formenbibliothek können Sie eine ERD manuell erstellen. Sie können dies tun, indem Sie das Formular aus der Formenbibliothek herausziehen und Relation, Text und Formatierung hinzufügen.

Tipp: Sparen Sie Zeit, indem Sie mit KI ein ERD erstellen. Mehr dazu erfahren Sie in unserem Artikel „Steigern Sie Ihre Produktivität mit Lucid AI in Lucidchart“ .

Hinzufügen oder Entfernen von Feldern

Um Felder hinzuzufügen oder zu entfernen, wählen Sie das Formular aus, klicken Sie auf das rechte Panel-Symbol in der oberen rechten Ecke der Leinwand oder auf die Formularbearbeitungsleiste, um das rechte Panel zu öffnen. Im Dropdown-Menü Erweiterte Optionen geben Sie die Anzahl der benötigten Felder an.

Informationen darüber, wie man Felder im klassischen Lucidchart-Editor hinzufügt oder entfernt, erweitern Sie bitte das untenstehende Dropdown-Menü.

Klicken Sie hier für klassische Informationen zum Lucidchart-Editor

UmFelder hinzuzufügen oder zu entfernen, wählen Sie das Formular aus oder klicken Sie auf das Kontextleiste-Symbol oben rechts auf der Leinwand, um das Entitäts-Kontextpanel zu öffnen. Im Dropdown-Menü Erweiterte Optionen geben Sie die Anzahl der benötigten Felder an.

 

Text hinzufügen

Doppelklicken Sie auf den Text, um in den Textbearbeitungsmodus zu gelangen. 

Sobald Sie ein Textfeld ausgewählt haben, können Sie Folgendes drücken:

  • Tab auf Ihrer Tastatur, um zur nächsten Zeile zu gelangen.
  • Verwenden Sie „Umschalttaste + Tab“, um zur vorherigen Zeile zu wechseln.
  • Drücken Sie die Eingabetaste oder klicken Sie in einen Bereich außerhalb des Objekts, um die Ansicht zu verlassen.

Größe der Entität anpassen

Um die Größe eines Objekts zu ändern, klicken Sie auf eine der Ecken und ziehen Sie den Mauszeiger in die gewünschte Richtung. Beim Verschieben eines Objekts wird die Größe der Spalten automatisch an den Inhalt angepasst.

Linien hinzufügen

Erstellen Sie eine Beziehungslinie zwischen zwei Entitäten, indem Sie von einem beliebigen Knoten auf einem Objekt klicken und ziehen. Du kannst die Linien auf ein anderes Formular ziehen und eine Relation zu einem bestimmten Feld erstellen.

Sie können den Mauszeiger auch über die Arbeitsfläche ziehen und loslassen, um automatisch ein neues Entitätsobjekt hinzuzufügen.

Hinweis: Wenn Sie Felder hinzufügen oder entfernen, nachdem Sie eine Beziehung erstellt haben, werden alle verbundenen Linien mit den Feldern bewegt, zu denen sie gehören. Sie müssen sie nicht neu einzeichnen.

reduzieren oder erweitern an Entität

Um eine Entität zu reduzieren oder zu erweitern, um Ihr Diagramm zu bereinigen oder zu vereinfachen, gehen Sie folgendermaßen vor:

  1. Wählen Sie die Entität aus, die Sie reduzieren oder erweitern möchten.
    • Es ist nicht möglich, mehr als eine Entität gleichzeitig zu reduzieren oder zu erweitern.
  2. Klicken Sie auf das Pfeil-Symbol, das oben rechts in der Entität erscheint.

Man kann auch eine Entität aus dem rechten Panel reduzieren oder erweitern, das erscheint, wenn eine Entität ausgewählt wird. Dazu klicken Sie im rechten Panel auf reduzieren Tabellen oder erweitern Tabellen .

Für Informationen zum Reduzieren oder Erweitern einer Entität im klassischen Lucidchart Editor erweitern Sie bitte das untenstehende Dropdown-Menü.

Klicken Sie hier für klassische Informationen zum Lucidchart-Editor

Sie können eine Entität auch über das Kontextfenster reduzieren oder erweitern, das auf der rechten Seite der Arbeitsfläche erscheint, wenn eine Entität ausgewählt ist. Klicken Sie dazu in der Registerkarte "Layout" unter "Erweiterte Optionen" auf Tabellen reduzieren oder Tabellen erweitern .

 

Formatierung von Linien

Um Formatierung zu den Linien Ihrer ERDhinzuzufügen:

  1. Wählen Sie eine Linie in Ihrem ERD -Diagramm aus.
  2. Klicken Sie in der angezeigten Formularbearbeitungsleiste, um das rechte Panel zu öffnen right-panel-icon.png .
  3. Im Abschnitt "Linien" im rechten Panel wählen Sie aus den Endpunkt-Dropdowns eine Option aus: setzen, bringen, einstellen new Linien endpoint Kardinalität.

Für Informationen zur Formatierung von Linien im klassischen Lucidchart Editor erweitern Sie bitte das untenstehende Dropdown-Menü.

Klicken Sie hier für klassische Informationen zum Lucidchart-Editor

Um die Linien Ihrer ERDFormatierung hinzuzufügen, wählen Sie die Linien aus und nutzen Sie das Dropdown-Menü in der Eigenschaftenleiste, um jedem der Endpunkte der Linien neue Kardinalität zuzuweisen. Die Standard-Linien für ein ERD ist der Ausgangspunkt der untenstehenden Bildschirmaufnahme.

 

Erklärung der ERD-Kardinalitäten

Kardinalität steht für die Beziehung zwischen Datenbank oder Entität. Jede Linienverbindung enthält verschiedene Symbole, um die Art der Beziehung zwischen den Entitäten widerzuspiegeln.

In diesem Leitfaden wird erklärt, welche Kardinalität jedes Symbol darstellt:

erd-cardinality-guide.png

Fügen Sie Schattierungen hinzu und ändern Sie die Header-Farbe

Vom Abschnitt "Erweitert" des rechten Panels aus können Sie:

  • Füge Schattierungen zu alternativen Zeilen eines Tabellen oder zum Tabellen-Header mit "Erweiterte Optionen" im rechten Panel hinzu.
  • Ändern Sie die Farbe der Schattierung der Kopfzeile oder abwechselnder Zeilen.

Für Informationen darüber, wie man im klassischen Lucidchart-Editor Schattierungen hinzufügen und die Kopfzeilenfarbe ändert, erweitern Sie bitte das untenstehende Dropdown-Menü.

Klicken Sie hier für klassische Informationen zum Lucidchart-Editor

Mit der erweiterten Formleiste können Sie die Schattierung Ihrer Entitätsobjekte anpassen. Hier sind Ihre Optionen:

  • Füge Schattierungen zu alternativen Zeilen eines Tabellen oder zum Tabellen-Header mit "Erweiterte Optionen" im Kontextleiste hinzu.
  • Ändern Sie die Farbe der Schattierung der Kopfzeile oder abwechselnder Zeilen.

 

Tipp: Werten Sie Ihr ERD auf, indem Sie es farblich kennzeichnen und einen Schlüssel hinzufügen. Weitere Informationen finden Sie in unserem Artikel „Hinzufügen eines Diagrammschlüssels in Lucidchart“ .

Ein ERD aktualisieren

Um eine aktualisierte Datenbankdatei in ein bestehendes ERD zu importieren, gehen Sie wie folgt vor:

  1. Wählen Sie Importieren in der Formenbibliothek für Entitätsbeziehungen auf der linken Seite aus. 
  2. Im erschienenen Pop-up wählen Sie eine der folgenden Optionen:
    • Nein, nur die Toolbox, um nur die Daten in der Toolbox zu aktualisieren.
    • Ja, um sowohl die Toolbox als auch die vorhandenen Formen im Dokument zu aktualisieren.

Ein ERD exportieren

Exportiere deine ERD in das DBMS (Datenbankverwaltungssystem) deiner Wahl, mit Ausnahme von Verbindungen zwischen Tabellen.
 

So exportieren Sie eine gesamte Seite:

  1. Klicken Sie auf right-panel-icon.png das rechte Panel-Symbol oben rechts auf der Leinwand.
  2. Wähle eine ERD-Form auf der Leinwand aus.
  3. Wählen Sie im rechten Panel "ERD exportieren ".
  4. Wählen Sie im angezeigten Fenster Ihr System im Dropdown-Menü aus.
  5. Kopiere die generierten Befehle aus der Codebox oder klicke auf Kopieren in Zwischenablage.
  6. Klicken Sie auf Fertig.

Für vollständige Anweisungen zum Exportieren und ERD im klassischen Lucidchart-Editor erweitern Sie bitte das Dropdown-Menü unten.

Klicken Sie hier für die klassischen Lucidchart Editor-Schritte

So exportieren Sie eine gesamte Seite:

  1. In der Entitätsrelation Formenbibliothek klicken Sie auf Export.
  2. Das Dialogfeld „Export nach SQL“ wird angezeigt. Wählen Sie ein DBMS aus dem Menü. 
  3. Klicken Sie auf Kopieren in die Zwischenablage, um die korrekte Aussage für die gesamte Seite zu kopieren.
  4. Klicken Sie auf Fertig.

FAQ

Warum erscheinen die Beziehung zwischen den Formen in meinem Diagramm nicht?

Wenn Lucidchart keine Linien zwischen den Entitäten Ihrer importierten ERD zeichnet, kann es sein, dass Ihre Datendatei die Beziehungen nicht über Primär- und Fremdschlüssel angibt. Um dies zu überprüfen, öffnen Sie bitte Ihre Datendatei und stellen Sie sicher, dass die Zellen am Ende jeder Zeile mit Informationen über die Beziehungen zwischen den Entitäten gefüllt sind.

Gibt es Einschränkungen beim Exportieren meines ERD?

Wenn Sie Ihr ERD in Quickbase exportieren, gibt es eine Höchstgrenze von 80 Tabellen und 50 Verknüpfungen. Ansonsten gibt es keine Einschränkungen, wenn Sie in ein anderes Format exportieren.

Wo ist das Importmenü aus der Formenbibliothek verschwunden?
Um eine aktualisierte Datenbankdatei in eine bestehende ERDzu importieren, folgen folgende Schritte:

  1. Klicken Sie file-menu-icon.png das Dateimenü-Symbol.
  2. halte deinen Cursor über "Datei".
  3. halte deinen Cursor über "Import".
  4. Klicken Sie auf Daten.
  5. Wähle Entitätsrelation (ERD).
  6. Klicken Sie auf das Dropdown-Menü "Daten importieren" und wählen Sie "Import from Salesforce" oder "Import from SQL-Datenbank".
    • Wenn Sie "Import from Salesfoce" auswählen, melden Sie sich in Ihr Salesforce-Konto ein und folgen Sie den Anweisungen.
    • Wenn Sie "Import from SQL-Datenbank" wählen, wählen Sie Ihr Datenbankverwaltungssystem (DBMS) und klicken Sie auf Nächsten. Dann wähle die Option entweder "Datei von deinem Computer hochladen" oder "Ausgabe als Klartext einfügen" und klicke auf Importieren.

Ressourcen

Weitere Informationen zu dieser Funktion finden Sie in den folgenden zusätzlichen Ressourcen. Diese Ressourcen sind nur auf Englisch verfügbar.

Community-Beitrag

Stellen Sie die Beziehungen zwischen Ihren Datenbanken dar, indem Sie ein ERD erstellen!

Vorlage
Datenbank ER-Diagramm (Krähenfuß)

DBMS-ER-Diagramm (UML-Notation)

Videos

Tutorial zum Entity-Relationship-Diagramm (ERD) – Teil 1

Tutorial zum Entity-Relationship-Diagramm (ERD) – Teil 2

Geben Sie Feedback zu diesem Artikel

Haben Sie Feedback zu diesem Artikel? Berichten Sie uns hier von Ihren Erfahrungen. 

Haben Sie gefunden wonach Sie gesucht haben?

Haben Sie noch eine Frage oder möchten Sie Ihre Erfahrungen mit anderen teilen? Besuchen Sie unsere Community,   um Hilfe zu bekommen und mit anderen zusammenzuarbeiten.